Requirements

You need Joomla 3.x, MySQL 5.7.8 and php 5.3.1 +, php 7+ recommended.

Here are Joomla's requirements.

You need a language pack for MyMuse in your language. If we do not have one contact us and we will start a translation.